• Начало
  • Поиск
    •  

Автор Тема: Корректный перенос типов значений плана видов характеристик  (Прочитано 1523 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WKBAPKA

  • Администратор
  • Новичок
  • *****
  • Сообщений: 24
  • Карма: +0/-0
  • Пол: Мужской
    • Внедренческий центр "КУБиК"
Долго искал, в книгах немного мутно, нашел одно решение.
В ПКО в свойства добавляем свойство и пишем код как в картинке


потом в самом ПКО пишем вот так



Оффлайн WKBAPKA

  • Администратор
  • Новичок
  • *****
  • Сообщений: 24
  • Карма: +0/-0
  • Пол: Мужской
    • Внедренческий центр "КУБиК"
Должно работать, если конфигурации одинаковые, иначе могут быть ошибки при загрузке.
Как более надежный вариант я сделал так.
В свойстве Типы вместо кода на картинке написал такой:

Если Источник.ЭтоГруппа = Ложь Тогда
ТипыСвойства = Источник.ТипЗначения.Типы();
Спс = Новый СписокЗначений;
Для Каждого ЭлМас Из ТипыСвойства Цикл
мТип = Метаданные.НайтиПоТипу(ЭлМас);
Спс.Добавить(мТип.ПолноеИмя());
КонецЦикла;

Значение = ЗначениеВСтрокуВнутр(Спс);
КонецЕсли;

А в ПКО в "После загрузки"  вместо кода на картинке написал вот такой:
Если Объект.ЭтоГруппа = Ложь Тогда
СпсТипы = ЗначениеИзСтрокиВнутр(ПараметрыОбъекта.Получить("Типы"));
Типы = Новый Массив;
Для Каждого Элемент Из СпсТипы Цикл
Разделитель = Найти(Элемент.Значение,".");
Вид = Сред(Элемент.Значение,1, Разделитель - 1);
Имя = Сред(Элемент.Значение, Разделитель + 1, СтрДлина(Элемент.Значение));
Сообщить(Вид + "Ссылка." + Имя);
Типы.Добавить(Тип(Вид + "Ссылка." + Имя));
КонецЦикла;

Объект.ТипЗначения = Новый ОписаниеТипов(Типы);
КонецЕсли;