• Начало
  • Поиск
    •  

Автор Тема: Обмен данными (РИБ) установить фильтр передачи данных  (Прочитано 2568 раз)

0 Пользователей и 1 Гость просматривают эту тему.

poritskiy

  • Гость
Есть база УТП, ...
сделал РИБ через план обменна Полный ,в такую же базу, все нормально работает но теперь захотели чтобы обмен происходил по тому Контрагенту в которого указа определенный "Основной менеджер"...
Как организовать такой фильтр?
При этом лутше переделать "Полный" план обмена или писать свой с нуля?
Если переделать полный план, то в каких процедурах это реализовывать ...
Познания в программировании слабые, подскажите что делать для решения этой задачи

Оффлайн WKBAPKA

  • Администратор
  • Новичок
  • *****
  • Сообщений: 24
  • Карма: +0/-0
  • Пол: Мужской
    • Внедренческий центр "КУБиК"
Один из вариантов решения данной задачи очищать регистрацию для данного объекта, если он не удовлетворяет условию... лучше всего это сделать с  помощью механизма подписки на события.
Если Источник.Контрагент.ОсновнойМенеджерКонтрагента.Пустая() Тогда
Источник.ОбменДанными.Получатели.Очистить();
Источник.ОбменДанными.Получатели.Автозаполнение = Ложь;
КонецЕсли;

Можно добавить свою подписку на событие и управлять регистрацией объектов для обмена согласно своим алгоритмам. Можно конечно и использовать методы объекта "ПланОбмена":
Процедура ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
КонецПроцедуры

Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента)
КонецПроцедуры

Процедура ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
КонецПроцедуры

Процедура ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
КонецПроцедуры

но это кому как нравиться и все зависит от конкретной решаемой задачи
« Последнее редактирование: 25 Сентября 2011, 11:49:34 от WKBAPKA »